RUOSI
Среда, 21.11.2018, 21:10



Приветствую Вас Гость | RSS
[ Главная ] [ Post Login - Форум ] [ Регистрация ] [ Вход ]
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Модератор форума: ruosi  
Форум » Ultima Online » Development / Разработка » Post Login
Post Login
centrifugalДата: Понедельник, 21.01.2008, 01:35 | Сообщение # 1
Группа: Пользователи
Сообщений: 1
Репутация: 0
Статус: Offline
Login to the game server
0x41 bytes
________________________________________
byte ID (91)
dword Auth ID
char[30] Name
char[30] Password

I wrote a simple server emulator for UO, I followed your protocol guide but I am seeing strange results. Now I will admit I am not very good with networking.
I attempted to login with clients 2.0.3 and 4.0.11c with removed encryption, I get same results with both.

Here is the Post Login Packet

Hex:
C0A82208063656E747269667567616C000000000000000000070617373776F72640000000000000000000000FF
Ascii:
??☻ ?centrifugal password

So according to this the ID would be C0 and not 91

I know I am doing something wrong, so can someone help me figure out why I get strange results?

Сообщение отредактировал centrifugal - Понедельник, 21.01.2008, 01:39
 
WarstoneДата: Понедельник, 09.06.2008, 20:46 | Сообщение # 2
Группа: Пользователи
Сообщений: 1
Репутация: 0
Статус: Offline
Try to look at zlib32(64).dll an figure out why they are in RunUO folder.

PS: Sorry for my English.

 
Форум » Ultima Online » Development / Разработка » Post Login
  • Страница 1 из 1
  • 1
Поиск:

Copyright RUOSI © 2018      Сайт управляется системой uCoz